还在找美国VPS取消Ubuntu系统意外关机后停留在GRUB界面的解决办法的靠谱教程?6G 站长网整理了美国VPS取消Ubuntu系统意外关机后停留在GRUB界面的解决办法从入门到精通的实操指南,解决新手操作云服务器时 “步骤混乱、配置出错、运维卡顿” 的核心痛点,手把手教你做好美国VPS取消Ubuntu系统意外关机后停留在GRUB界面的解决办法,哪怕是第一次接触云服务器也能快速上手。

美国VPS装了Ubuntu之后的现象:

Ubuntu意外断电关机重启进入GRUB引导界面不动,必须手动回车后才能进系统。

原因:

查看 /boot/grub/grub.cfg

if [ "${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=2
正是被这个-1给停留到启动界面的

解决办法:

先将/boot/grub/grub.cfg 默认只读修改为可写入

cd /boot/grub

chmod 644 grub.cfg 修改成root用户可写

然后

Vi /boot/grub/grub.cfg 找到 timeout

if [ "${recordfail}" = 1 ]; then

set timeout=-1 改为 0
修改后wq退出既可